Google no te permitirá descargar aplicaciones obsoletas

Google.

Apple se toma muy enserio el papel de controlar las apps que se pueden descargar desde su tienda de aplicaciones; cuando la compañía encuentra una aplicación que no es compatible con las últimas versiones de iOS o con los celulares más recientes, la elimina de App Store. Ahora, Google está haciendo lo mismo.

A través de una publicación en su blog oficial Google anunció que “a partir del 1 de noviembre de 2022, las aplicaciones existentes que no tengan como objetivo un nivel de API dentro de los dos años posteriores a la última versión principal de Android no estarán disponibles para su descubrimiento o instalación para nuevos usuarios con dispositivos que ejecutan Android”

Esto es beneficioso para la experiencia del usuario con las apps en sus dispositivos; pues al dejar solamente aquellas aplicaciones compatibles con las últimas versiones del sistema operativo, correrán de manera adecuada. Sin embargo, se dificulta la conservación de aplicaciones y juegos que están diseñados para versiones más antiguas.

Te puede interesar: Ahora podrás pagar tus compras en Play Store con ‘Play Points’

Pero Google no le ha cerrado las puertas totalmente a estas apps obsoletas; en su comunicado también argumentaron que “A medida que se lancen nuevas versiones del sistema operativo Android en el futuro, la ventana de requisitos se ajustará en consecuencia”. Es decir, si una aplicación es eliminada de Google Play Store por ser obsoleta, los desarrolladores tendrán la opción de actualizarla para continuar ofreciendo sus servicios.

Entendamos mejor esto. Las aplicaciones para Android se desarrollan teniendo en cuenta dos versiones del sistema operativo. El primero es el nivel mínimo de API, es decir, la versión más antigua de Android con la que puede ser compatible la app. Por otro lado, tenemos el nivel de API “objetivo”, esta es la versión de Android más reciente para la que está diseñada. No obstante, los desarrolladores deben mantener el nivel de API de destino bastante cerca a la versión más reciente de Android, para poder utilizar las últimas API y funciones de desarrollo.

Con este anuncio, Google también pretende mejorar la privacidad y seguridad de sus usuarios; al obligar a las aplicaciones a desarrollarlas para las versiones más recientes, se deben mantener al día con los cambios de seguridad y permisos.

Imagen: Freepik

Alejandra Betancourt

Alejandra Betancourt

Dicen que una buena manera de viajar es a través de la lectura, a mí me gusta navegar entre las letras y construir también mis propios trayectos. Me interesa que todos sepamos lo que sucede en el mundo, así que estudié Comunicación Social. Actualmente y con el propósito de escribir mis cuentos y próximas novelas, estudio Creación Literaria.

View all posts

Add comment

Tu dirección de correo electrónico no será publicada.

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.

Archivos